Unverified Commit c51945dd authored by Marco Malavolti's avatar Marco Malavolti Committed by GitHub
Browse files

Update README.md

parent 11d4e71c
......@@ -112,16 +112,16 @@ The tool uses following status for IdPs:
### Python 3.8
1. Download the last version of Python 3.8.x from https://www.python.org/downloads/source/:
* `wget https://www.python.org/ftp/python/3.8.3/Python-3.8.3.tgz -O /usr/local/src/Python-3.8.3.tar.gz`
* `sudo wget https://www.python.org/ftp/python/3.8.3/Python-3.8.3.tgz -O /usr/local/src/Python-3.8.3.tar.gz`
2. Extract Python source package:
* `cd /usr/local/src/`
* `tar xzf Python-3.8.3.tar.gz`
* `sudo tar xzf Python-3.8.3.tar.gz`
3. Build Python from the source package:
* `cd /usr/local/src/Python-3.8.3`
* `./configure --enable-optimizations`
* `make -j 4`
* `sudo ./configure --enable-optimizations`
* `sudo make -j 4`
4. Install Python 3.8.x (without replacing the system `python3` command) under `/usr/local/bin/python3.8`:
* `sudo make altinstall`
......@@ -130,20 +130,19 @@ The tool uses following status for IdPs:
5. Create link of Python3.8 for scripts:
* `sudo ln -s /usr/local/bin/python3.8 /usr/bin/python3.8`
# Install requirements for uWSGI used by ECCS2 API
# Install Chromium needed by Selenium
* Debian:
* `sudo apt-get install libpcre3 libpcre3-dev libapache2-mod-proxy-uwsgi build-essentials python3-dev unzip`
* `sudo apt install chromium git jq`
* CentOS:
* `sudo yum install mod_proxy_uwsgi unzip`
* Enable ECCS2 for SELinux:
* `semanage fcontext -a -t httpd_sys_content_t "/opt/eccs2(/.*)?"`
* `restorecon -R -a /opt/eccs2/`
* `sudo yum install -y epel-release`
* `sudo yum install -y chromium git jq`
# Install Selenium and Chromedriver
* `python3.8 -m pip install --upgrade pip`
* `python3.8 -m pip install selenium virtualenv uwsgi`
* `sudo python3.8 -m pip install --upgrade pip`
* `sudo python3.8 -m pip install selenium virtualenv`
* `sudo wget https://chromedriver.storage.googleapis.com/83.0.4103.39/chromedriver_linux64.zip -O /usr/local/src/chromedriver_linux64.zip`
* `cd /usr/bin/`
* `sudo unzip /usr/local/src/chromedriver_linux64.zip`
......@@ -154,14 +153,6 @@ Note: Pay attetion on the chromedriver version:
* CentOS 7.8:
* `chromium-browser -version` => Chromium 83.0.4103.116 => https://chromedriver.storage.googleapis.com/83.0.4103.39/chromedriver_linux64.zip
# Install Chromium needed by Selenium
* Debian:
* `sudo apt install chromium git jq`
* CentOS:
* `sudo yum install -y epel-release`
* `sudo yum install -y chromium git jq`
# ECCS2
......@@ -169,10 +160,10 @@ Note: Pay attetion on the chromedriver version:
* `cd /opt ; git clone https://github.com/malavolti/eccs2.git`
* `cd eccs2`
* `virtualenv -p python38 eccs2venv`
* `virtualenv --python=/usr/bin/python3.8 eccs2venv`
* `source eccs2venv/bin/activate` (`deactivate` to exit Virtualenv)
* `pip install --upgrade pip`
* `pip install -r requirements.txt`
* `python3.8 -m pip install --upgrade pip uwsgi`
* `python3.8 -m pip install -r requirements.txt`
## Configure
......@@ -217,6 +208,16 @@ Note: Pay attetion on the chromedriver version:
The "--test" parameter will not change the result of ECCS2, but will write the output on the `logs/stdout_idp_YYYY-MM-DD.log`,`logs/stderr_idp_YYYY-MM-DD.log` and `logs/failed-cmd-idp.sh` files.
# Install requirements for uWSGI used by ECCS2 API
* Debian:
* `sudo apt-get install libpcre3 libpcre3-dev libapache2-mod-proxy-uwsgi build-essentials python3-dev unzip`
* CentOS:
* `sudo yum install mod_proxy_uwsgi unzip`
* Enable ECCS2 for SELinux:
* `sudo semanage fcontext -a -t httpd_sys_content_t "/opt/eccs2(/.*)?"`
* `sudo restorecon -R -e /opt/eccs2/`
# ECCS2 API Development Server
* `cd /opt/eccs2 ; ./api.py`
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment